Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Denial of Service >> Communigate Pro LDAP Module Denial of Service Vulnerability


Vulnerability Assessment Details

Communigate Pro LDAP Module Denial of Service Vulnerability

Vulnerability Assessment Summary
Checks for denial of service vulnerability in Communigate Pro LDAP module

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote application is prone to denial of service attacks.

Description :

The remote host appears to be running CommuniGate Pro, a commercial
email and groupware application.

The version of CommuniGate Pro installed on the remote host includes
an LDAP server that reportedly fails to handle requests with negative
BER lengths. A user can leverage this issue to crash not just the
LDAP server but also the entire application on the remote host.
Remote code execution may even be possible.

See also :

http://www.securityfocus.com/archive/1/423364
http://lists.grok.org.uk/pipermail/full-disclosure/2006-January/041863.html
http://mail.communigate.com/Lists/CGatePro/Message/82832.html

Solution :

Upgrade to CommuniGate Pro version 5.0.7 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 16407

Vulnerability Assessment Copyright: This script is Copyright (C) 2006-2007 Tenable Network Security

Cables, Connectors

ST1000LM014, PN 1EJ164-021, FW HPM6, Seagate 1TB SATA 2.5 100705349 REV D
$20.0
ST1000LM014, PN 1EJ164-021, FW HPM6, Seagate 1TB SATA 2.5 100705349 REV D  pictureHP Z440 WORKSTATION W7 PRO E5-2637V4 3.5GHz 48GB 2 X 1TB SSD QUADRO K2000 2GB
$3289.0
HP Z440 WORKSTATION W7 PRO E5-2637V4 3.5GHz 48GB 2 X 1TB SSD QUADRO K2000 2GB pictureHP Z640 W7 TWO E5-2650V4 2.2GHZ 64GB 1TB SSD NO VID
$5449.0
HP Z640 W7 TWO E5-2650V4 2.2GHZ 64GB 1TB SSD NO VID pictureDELL POWEREDGE R730XD SERVER 12 BAY E5-2609V4 1.7GHz 16GB 300GB 15K SAS 2 X 1TB
$2829.0
DELL POWEREDGE R730XD SERVER 12 BAY E5-2609V4 1.7GHz 16GB 300GB 15K SAS 2 X 1TB picture


Discussions

No Discussions have been posted on this vulnerability.