Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Claroline extAuthSource Parameter Array Remote File Include Vulnerability


Vulnerability Assessment Details

Claroline extAuthSource Parameter Array Remote File Include Vulnerability

Vulnerability Assessment Summary
Tries to read a local file with Claroline

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
remote file inclusion attack.

Description :

The remote host is running Claroline, an open-source, web-based,
collaborative learning environment written in PHP.

The version of Claroline installed on the remote host fails to
sanitize input to the 'extAuthSource' parameter array before using it
to include PHP code in the 'claroline/inc/claro_init_local.inc.php'
script. Provided PHP's 'register_globals' setting is enabled, an
unauthenticated attacker may be able to exploit this issue to view
arbitrary files on the remote host or to execute arbitrary PHP code,
possibly taken from third-party hosts.

See also :

http://www.gulftech.org/?node=research&article_id=00112-09142006
http://www.claroline.net/wiki/index.php/Changelog_1.7.x

Solution :

Either apply the security patch to version 1.7.7 or upgrade to
Claroline 1.7.8 or later.

Network Security Threat Level:

Medium / CVSS Base Score : 6
(AV:R/AC:H/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 20056

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

Dell PowerEdge R820 4 x 8C E5-4650 2.7GHZ,384GB,8x1.2TB SAS,iDRAC Ent
$2195.0
Dell PowerEdge R820 4 x 8C E5-4650 2.7GHZ,384GB,8x1.2TB SAS,iDRAC Ent pictureDell PowerEdge T410 Tower Server Xeon E5506 Quad Core 2.13GHz 4GB RAM No HDDs
$13.46
Dell PowerEdge T410 Tower Server Xeon E5506 Quad Core 2.13GHz 4GB RAM No HDDs pictureDell PowerEdge T110 Tower Server Xeon QC X3430 2.40GHz 8GB RAM no HDD
$8.97
Dell PowerEdge T110 Tower Server Xeon QC X3430 2.40GHz 8GB RAM no HDD pictureDell PowerEdge T310 Tower Server Xeon X3430 QC 2.40GHz 8GB RAM PERC 6/i No HDDs
$13.46
Dell PowerEdge T310 Tower Server Xeon X3430 QC 2.40GHz 8GB RAM PERC 6/i No HDDs  picture


Discussions

No Discussions have been posted on this vulnerability.