Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Claroline < 1.5.4 / 1.6.0 Multiple Input Validation Vulnerabilities


Vulnerability Assessment Details

Claroline < 1.5.4 / 1.6.0 Multiple Input Validation Vulnerabilities

Vulnerability Assessment Summary
Checks for multiple input validation vulnerabilities in Claroline < 1.5.4 / 1.6.0

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP application that is prone to a
variety of attacks.

Description :

The version of Claroline (an open source, collaborative learning
environment) installed on the remote host suffers from a number of
remotely-exploitable vulnerabilities, including:

- Multiple Remote File Include Vulnerabilities
Four scripts let a possible hacker read arbitrary files on the
remote host and possibly even run arbitrary PHP code,
subject to the rights of the web server user.

- Multiple SQL Injection Vulnerabilities
Seven scripts let a possible hacker inject arbitrary input
into SQL statements, potentially revealing sensitive
data or altering them.

- Multiple Cross-Site Scripting Vulnerabilities
A possible hacker can pass arbitrary HTML and script code
through any of 10 flawed scripts and potentially have
that code executed by a user's browser in the context
of the affected web site.

- Multiple Directory Traversal Vulnerabilities
By exploiting flaws in 'claroline/document/document.php'
and 'claroline/learnPath/insertMyDoc.php', project leaders
(teachers) are able to upload files to arbitrary folders
or copy/move/delete (then view) files of arbitrary folders.

See also :

http://www.zone-h.org/advisories/read/id=7472

Solution :

Upgrade to Claroline version 1.5.4 / 1.6.0 or later.

Network Security Threat Level:

High / CVSS Base Score : 7
(AV:R/AC:L/Au:NR/C:P/A:P/I:P/B:N)

Networks Security ID: 13407

Vulnerability Assessment Copyright: This script is Copyright (C) 2005-2006 Tenable Network Security

Cables, Connectors

HP ProLiant DL380p G8 Dual E5-2690 8 Core 2.9GHz 16GB 8x 146GB 15K SAS Rails RPS
$1360.0
HP ProLiant DL380p G8 Dual E5-2690 8 Core 2.9GHz 16GB 8x 146GB 15K SAS Rails RPS pictureHP ProLiant DL380p G8 Dual E5-2660 8 Core 2.2GHz 32GB 8x 600GB 15K SAS Rails RPS
$3484.0
HP ProLiant DL380p G8 Dual E5-2660 8 Core 2.2GHz 32GB 8x 600GB 15K SAS Rails RPS pictureHP Renew ProLiant DL380 G9 Single E5-2620 v4 8-Core 2.1GHz 32GB 8x 600GB 15K SAS
$4462.0
HP Renew ProLiant DL380 G9 Single E5-2620 v4 8-Core 2.1GHz 32GB 8x 600GB 15K SAS pictureHP ProLiant DL380p G8 Server Dual E5-2660 8 Core 2.2GHz 128GB 8x 300GB 15K SAS
$2202.0
HP ProLiant DL380p G8 Server Dual E5-2660 8 Core 2.2GHz 128GB 8x 300GB 15K SAS picture


Discussions

No Discussions have been posted on this vulnerability.