Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> Citadel/UX select() bitmap remote buffer overflow


Vulnerability Assessment Details

Citadel/UX select() bitmap remote buffer overflow

Vulnerability Assessment Summary
Checks the version of the remote Citadel server

Detailed Explanation for this Vulnerability Assessment

The remote host is running Citadel/UX, a BBS software for Unix systems.

The remote version of this software is vulnerable to buffer overflow
when performing a select() system call while providing very high file
descriptors. A possible hacker may exploit this flaw to modify at least one byte
in memory.

Solution : Upgrade to Citadel 6.29 (when available) or newer
Network Security Threat Level: High

Networks Security ID: 12344

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

Lenovo Yoga 710 15.6” Intel i7/ 16GB RAM/ 256GB SSD/ NVIDIA 940M/ 4K Display
$790.0
Lenovo Yoga 710 15.6” Intel i7/ 16GB RAM/ 256GB SSD/ NVIDIA 940M/ 4K Display pictureMushkin STEALTH 16GB (2 x 8GB) 240-Pin DDR3 SDRAM 1600 PC3 12800 Desktop Memory
$95.99
Mushkin STEALTH 16GB (2 x 8GB) 240-Pin DDR3 SDRAM 1600 PC3 12800 Desktop Memory pictureG.SKILL Flare X Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) A
$299.95
G.SKILL Flare X Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 3200 (PC4 25600) A pictureLenovo 0B47381 Lenovo.Memory 8 GB DIMM 204-pin Connector 1600 MHz (PC3-12800) Un
$132.0
Lenovo 0B47381 Lenovo.Memory 8 GB DIMM 204-pin Connector 1600 MHz (PC3-12800) Un picture


Discussions

No Discussions have been posted on this vulnerability.