Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> CVSWeb 1.80 gives a shell to cvs committers


Vulnerability Assessment Details

CVSWeb 1.80 gives a shell to cvs committers

Vulnerability Assessment Summary
Checks if CVSWeb is present and gets its version

Detailed Explanation for this Vulnerability Assessment

The remote cvsweb is older or as old as version 1.85.

This version permits a cvs committer to execute arbitrary
commands on your server, with the rights of the
HTTPd process.

Solution : upgrade to version 1.86 (http://stud.fh-heilbronn.de/~zeller/cgi/cvsweb.cgi/)
Network Security Threat Level: High

Networks Security ID: 1469

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Renaud Deraison

Cables, Connectors

HP DL380 G9 8-Core Server 2x E5-2623 v3 3.0GHz 384GB-16 4x 960GB SSD H240ar
$5612.95
HP DL380 G9 8-Core Server 2x E5-2623 v3 3.0GHz 384GB-16 4x 960GB SSD H240ar pictureHP DL380 G10 8-Core Server 1x Silver 4108 1.8GHz 64GB-16 8x 4TB 12G E208i LFF
$5101.0
HP DL380 G10 8-Core Server 1x Silver 4108 1.8GHz 64GB-16 8x 4TB 12G E208i LFF pictureHP DL360 G9 8-Core Server 2x E5-2623 v3 3.0GHz 32GB-16 8x 300GB SAS P440ar
$2047.4
HP DL360 G9 8-Core Server 2x E5-2623 v3 3.0GHz 32GB-16 8x 300GB SAS P440ar pictureHP DL360 G9 8-Core Server 2x E5-2623 v3 3.0GHz 32GB-16 4x 146GB 15K SAS P440ar
$1825.55
HP DL360 G9 8-Core Server 2x E5-2623 v3 3.0GHz 32GB-16 4x 146GB 15K SAS P440ar picture


Discussions

No Discussions have been posted on this vulnerability.