Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> CUPS < 1.1.23 Multiple Vulnerabilities


Vulnerability Assessment Details

CUPS < 1.1.23 Multiple Vulnerabilities

Vulnerability Assessment Summary
Checks version of CUPS

Detailed Explanation for this Vulnerability Assessment

The remote host is running a CUPS server whose version number is
between 1.0.4 and 1.1.22 inclusive. Such versions are prone to
multiple vulnerabilities :

- A remotely exploitable buffer overflow in the 'hpgltops'
filter that enable specially crafted HPGL files can
execute arbitrary commands as the CUPS 'lp' account.

- A local user may be able to prevent anyone from changing
his or her password until a temporary copy of the new
password file is cleaned up ('lppasswd' flaw).

- A local user may be able to add arbitrary content to the
password file by closing the stderr file descriptor
while running lppasswd (lppasswd flaw).

- A local attacker may be able to truncate the CUPS
password file, thereby denying service to valid clients
using digest authentication. (lppasswd flaw).

- The application applys ACLs to incoming print jobs in a
case-sensitive fashion. Thus, a possible hacker can bypass
restrictions by changing the case in printer names when
submitting jobs. [Fixed in 1.1.21.]

***** Nessus has acertaind the vulnerability exists simply
***** by looking at the version number of CUPS installed on
***** the remote host.

See also : http://www.cups.org/str.php?L700
http://www.cups.org/str.php?L1024
http://www.cups.org/str.php?L1023
Solution : Upgrade to CUPS 1.1.23 or later.
Network Security Threat Level: High

Networks Security ID: 11968, 12004, 12005, 12007, 12200, 14265

Vulnerability Assessment Copyright: This script is Copyright (C) 2005 George A. Theall

Cables, Connectors

Cobalt Networks RAQ 4 Microserver, server appliance
$29.0
Cobalt Networks RAQ 4 Microserver, server appliance  pictureHPE ProLiant MicroServer Gen8 Server Xeon E3-1220Lv2 2.3 8GB 4TB HDD 783959-S01
$810.0
HPE ProLiant MicroServer Gen8 Server Xeon E3-1220Lv2 2.3 8GB 4TB HDD 783959-S01  pictureSuper Micro H8DAR-T w/ AMD Opteron 250 x2 @ 2.4 GHz, 2 GB RAM
$39.99
Super Micro H8DAR-T w/ AMD Opteron 250 x2 @ 2.4 GHz, 2 GB RAM picturePERFECT Intel Server Motherboard - Super Micro Computer X8DTT-F - Socket LGA1366
$29.99
PERFECT Intel Server Motherboard - Super Micro Computer X8DTT-F - Socket LGA1366 picture


Discussions

No Discussions have been posted on this vulnerability.