Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Bonsai Mutiple Flaws


Vulnerability Assessment Details

Bonsai Mutiple Flaws

Vulnerability Assessment Summary
Determine if bonsai is vulnerable to xss attack

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote host contains a CGI which is vulnerable to multiple flaws
permiting code execution and cross-site scripting attacks.

Description :

The remote host has the CGI suite 'Bonsai' installed.

This suite is used to browse a CVS repository with a web browser.

The remote version of this software is to be vulnerable to various
flaws ranging from path disclosure and cross site scripting to remote
command execution.

A possible hacker may exploit these flaws to temper with the integrity of
the remote host.

Solution :

Upgrade to the latest version of Bonsai

Network Security Threat Level:

Critical / CVSS Base Score : 10
(AV:R/AC:L/Au:NR/C:C/A:C/I:C/B:N)

Networks Security ID: 5516, 5517

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

DLink 16 port 10/100 Switch
$40.0
DLink 16 port 10/100 Switch pictureTRENDnet TEG-S80G 8-Port Gigabit GREENnet Hub / Switch
$19.95
TRENDnet TEG-S80G 8-Port Gigabit GREENnet Hub / Switch pictureHP/Compaq StorageWorks Modular SAN Array MSA Fabric Switch 6 218681-001
$42.93
HP/Compaq StorageWorks Modular SAN Array MSA Fabric Switch 6 218681-001 pictureHP 4Gb Virtual Connect Fibre Channel Module - C3000/C7000 409513-B21/410152-001
$39.03
HP 4Gb Virtual Connect Fibre Channel Module - C3000/C7000 409513-B21/410152-001 picture


Discussions

No Discussions have been posted on this vulnerability.