Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> BEA WebLogic Scripts Server scripts Source Disclosure


Vulnerability Assessment Details

BEA WebLogic Scripts Server scripts Source Disclosure

Vulnerability Assessment Summary
BEA WebLogic may be tricked into revealing the source code of JSP scripts.

Detailed Explanation for this Vulnerability Assessment

BEA WebLogic may be tricked into revealing the source code of JSP scripts
by using simple URL encoding of characters in the filename extension.

e.g.: default.js%70 (=default.jsp) won't be considered as a script but
rather as a simple document.

Vulnerable systems: WebLogic version 5.1.0 SP 6

Immune systems: WebLogic version 5.1.0 SP 8

Solution: Use the official patch available at http://www.bea.com

Network Security Threat Level: Medium

Networks Security ID: 2527

Vulnerability Assessment Copyright: INTRANODE - 2001

Cables, Connectors

Samsung 16GB (4x4GB) PC3L-10600R DDR3 ECC Server Memory RAM M393B5273CH0-YH9
$26.0
Samsung 16GB (4x4GB) PC3L-10600R DDR3 ECC Server Memory RAM M393B5273CH0-YH9 pictureDell PowerEdge R720 Server 2.80Ghz 20-Core 288GB 3x 300GB 15K 9x 3TB High-End
$3172.4
Dell PowerEdge R720 Server 2.80Ghz 20-Core 288GB 3x 300GB 15K 9x 3TB High-End pictureAvocent ACS6004-SAC 4 Port Advanced Console Server w/ Single AC Power
$55.0
Avocent ACS6004-SAC 4 Port Advanced Console Server w/ Single AC Power  pictureDELL POWEREDGE R730XD SERVER 12 BAY E5-2650LV3 1.8GHZ 32GB 2TB SAS 2 X 900GB 10K
$3219.0
DELL POWEREDGE R730XD SERVER 12 BAY E5-2650LV3 1.8GHZ 32GB 2TB SAS 2 X 900GB 10K picture


Discussions

No Discussions have been posted on this vulnerability.