Vulnerability Assessment & Network Security Forums

If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.

Home >> Browse Vulnerability Assessment Database >> CGI abuses >> AutomatedShops WebC.cgi buffer overflows

Vulnerability Assessment Details

AutomatedShops WebC.cgi buffer overflows

Vulnerability Assessment Summary
Searches for the existence of webc.cgi

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of AutomatedShops's webc.cgi
which is older than version 5.020.

This CGI is vulnerable to a remote buffer overflow (up to version 5.005 included)
and to a local one (up to version 5.010 included)

A possible hacker may use this flaw to execute arbitrary code on the remote

Solution : Upgrade to version 5.020
Network Security Threat Level: High

Networks Security ID: 7268

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors


No Discussions have been posted on this vulnerability.