Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> AutomatedShops WebC.cgi buffer overflows


Vulnerability Assessment Details

AutomatedShops WebC.cgi buffer overflows

Vulnerability Assessment Summary
Searches for the existence of webc.cgi

Detailed Explanation for this Vulnerability Assessment

The remote host is running a version of AutomatedShops's webc.cgi
which is older than version 5.020.

This CGI is vulnerable to a remote buffer overflow (up to version 5.005 included)
and to a local one (up to version 5.010 included)

A possible hacker may use this flaw to execute arbitrary code on the remote
host.

Solution : Upgrade to version 5.020
Network Security Threat Level: High

Networks Security ID: 7268

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

HP DL380 G9 16-Core Server 2x E5-2630 v3 2.4GHz 64GB-16 8x 1.2TB 12G SAS H240ar
$5222.9
HP DL380 G9 16-Core Server 2x E5-2630 v3 2.4GHz 64GB-16 8x 1.2TB 12G SAS H240ar pictureHP DL360p G8 12-Core Server 2x E5-2640 2.5GHz 128GB-16 2x 6TB SAS 4 Bay LFF
$1189.5
HP DL360p G8 12-Core Server 2x E5-2640 2.5GHz 128GB-16 2x 6TB SAS 4 Bay LFF pictureHP DL380p G8 16-Core Server 2x E5-2650 2.0GHz 384GB-16 4x 1.2TB SAS SFF RPS
$3258.0
HP DL380p G8 16-Core Server 2x E5-2650 2.0GHz 384GB-16 4x 1.2TB SAS SFF RPS picture


Discussions

No Discussions have been posted on this vulnerability.