Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain a shell remotely >> Apache-SSL overflow


Vulnerability Assessment Details

Apache-SSL overflow

Vulnerability Assessment Summary
Checks for version of Apache-SSL

Detailed Explanation for this Vulnerability Assessment

The remote host is using a version of Apache-SSL which is
older than 1.47

This version is vulnerable to a buffer overflow which,
albeit difficult to exploit, may permit a possible hacker
to obtain a shell on this host.


Solution : Upgrade to version 1.47 or newer
Network Security Threat Level: High

Networks Security ID: 4189

Vulnerability Assessment Copyright: This script is Copyright (C) 2002 Renaud Deraison

Cables, Connectors

Dell OptiPlex 3020 MT Desktop i3 4160 3.6GHz 4GB 1TB Windows 10 #ab
$139.0
Dell OptiPlex 3020 MT Desktop i3 4160 3.6GHz 4GB 1TB Windows 10 #ab  pictureDELL POWEREDGE M630 E5-2695V4 2.1GHZ 256GB 1TB SATA H730
$5579.0
DELL POWEREDGE M630 E5-2695V4 2.1GHZ 256GB 1TB SATA H730 pictureDELL T7910 WORKSTATION E5-2683V4 2.1GHz 48GB 3 X 1TB SSD QUADRO P6000
$9729.0
DELL T7910 WORKSTATION E5-2683V4 2.1GHz 48GB 3 X 1TB SSD QUADRO P6000 pictureDELL T7810 WORKSTATION E5-2660V3 2.6GHZ 32GB 1TB SATA 6000
$4329.0
DELL T7810 WORKSTATION E5-2660V3 2.6GHZ 32GB 1TB SATA 6000 picture


Discussions

No Discussions have been posted on this vulnerability.