Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Web Servers >> Apache < 2.0.45


Vulnerability Assessment Details

Apache < 2.0.45

Vulnerability Assessment Summary
Checks for version of Apache

Detailed Explanation for this Vulnerability Assessment

The remote host appears to be running a version of
Apache 2.x which is older than 2.0.45

This version is vulnerable to various flaws :

- There is a denial of service attack which may permit
a possible hacker to disable this server remotely

- The httpd process leaks file descriptors to child processes,
such as CGI scripts. A possible hacker who has the ability to execute
arbitrary CGI scripts on this server (including PHP code) would
be able to write arbitrary data in the file pointed to (in particular,
the log files)

Solution : Upgrade to version 2.0.45
See also : http://www.apache.org/dist/httpd/CHANGES_2.0
Network Security Threat Level: High

Networks Security ID: 7254, 7255

Vulnerability Assessment Copyright: This script is Copyright (C) 2003 Renaud Deraison

Cables, Connectors

Juniper EX4500-LB Intraconnect Plug-In Network Module Board for EX4500 Switch
$179.0
Juniper EX4500-LB Intraconnect Plug-In Network Module Board for EX4500 Switch pictureJuniper Virtual Chassis Port Cable EX-CBL-VCP-50CM Stacking Cable
$85.0
Juniper Virtual Chassis Port Cable EX-CBL-VCP-50CM Stacking Cable pictureJuniper SRX 240H-POE
$219.4
Juniper SRX 240H-POE pictureJuniper SSG5
$14.62
Juniper SSG5 picture


Discussions

No Discussions have been posted on this vulnerability.