Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> Advanced Guestbook phpbb_root_path Parameter Remote File Include Vulnerability


Vulnerability Assessment Details

Advanced Guestbook phpbb_root_path Parameter Remote File Include Vulnerability

Vulnerability Assessment Summary
Tries to read /etc/passwd using Advanced Guestbook

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server contains a PHP script that is affected by a
remote file include issue.

Description :

The remote host is running Advanced Guestbook, a free guestbook
written in PHP.

The version of Advanced Guestbook installed on the remote host fails
to sanitize input to the 'phpbb_root_path' parameter of the
'admin/addentry.php' script before using it in a PHP 'include()'
function. Provided PHP's 'register_globals' setting is enabled, an
unauthenticated attacker may be able to exploit this issue to view
arbitrary files on the remote host or to execute arbitrary PHP code,
possibly taken from third-party hosts.

See also :

http://milw0rm.com/exploits/1723

Solution :

Upgrade to Advanced Guestbook version 2.4.1 or later.

Network Security Threat Level:

High / CVSS Base Score : 7.0
(AV:R/AC:L/Au:NR/C:P/I:P/A:P/B:N)

Networks Security ID: 17745

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

StarTech USB 2.0 Print Server 10/100 MBPs PM1115U PC Mac Linux NEW
$20.0
StarTech USB 2.0 Print Server 10/100 MBPs PM1115U PC Mac Linux NEW pictureiDRAC7 Enterprise License for Dell 12th Gen Server
$60.0
iDRAC7 Enterprise License for Dell 12th Gen Server pictureUbuntu 18.04.1, 16.04.5 or 14.04.5 LTS│Linux│USB│Desktop or Server│32/64bit
$10.2
Ubuntu 18.04.1, 16.04.5 or 14.04.5 LTS│Linux│USB│Desktop or Server│32/64bit pictureUbuntu 18.04.1, 16.04.5 or 14.04.5 LTS│Linux│USB│Desktop or Server│32/64bit
$10.2
Ubuntu 18.04.1, 16.04.5 or 14.04.5 LTS│Linux│USB│Desktop or Server│32/64bit picture


Discussions

No Discussions have been posted on this vulnerability.