Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Gain root remotely >> AT-TFTP Server Long Filename Buffer Overflow Vulnerability


Vulnerability Assessment Details

AT-TFTP Server Long Filename Buffer Overflow Vulnerability

Vulnerability Assessment Summary
Checks for a buffer overflow vulnerability in AT-TFTP Server

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote tftp server is affected by a buffer overflow vulnerability.

Description :

The remote host appears to be running AT-TFTP Server, a tftpd server
for Windows.

The version of AT-TFTP Server installed on the remote host appears to
be affected by a buffer overflow vulnerability involving a long
filenames when getting or putting files. By leveraging this flaw, a
remote attacker may be able to crash the remote service or to execute
code on the affected host subject to the rights under which the
server operates.

See also :

http://aluigi.altervista.org/adv/attftp-adv.txt
http://www.securityfocus.com/archive/1/452743/30/0/threaded

Solution :

Unknown at this time.

Network Security Threat Level:

Critical / CVSS Base Score : 10.0
(AV:R/AC:L/Au:NR/C:C/I:C/A:C/B:N)

Networks Security ID: 21320

Vulnerability Assessment Copyright: This script is Copyright (C) 2006 Tenable Network Security

Cables, Connectors

QNAP TS-1273U-RP 24tb SSD NAS Server 12x2000gb Samsung 860 EVO Drives
$9090.0
QNAP TS-1273U-RP 24tb SSD NAS Server 12x2000gb Samsung 860 EVO Drives pictureQNAP TS-677 1tb SSD NAS Server 4x250gb Crucial MX500 Drives
$2037.0
QNAP TS-677 1tb SSD NAS Server 4x250gb Crucial MX500 Drives picture


Discussions

No Discussions have been posted on this vulnerability.