Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> ASP source using ::$DATA trick


Vulnerability Assessment Details

ASP source using ::$DATA trick

Vulnerability Assessment Summary
downloads the source of ASP scripts

Detailed Explanation for this Vulnerability Assessment

Summary :

The remote web server is affected by an information disclosure flaw.

Description :

It is possible to get the source code of a remote ASP script by
appending '::$DATA' to the end of the request. ASP source code
usually contains sensitive information such as logins and passwords.

See also :

http://www.microsoft.com/technet/security/bulletin/ms98-003.mspx

Solution :

Apply the hotfixes referenced in the vendor advisory above.

Network Security Threat Level:

Low / CVSS Base Score : 1
(AV:R/AC:L/Au:R/C:P/A:N/I:N/B:N)

Networks Security ID: 149

Vulnerability Assessment Copyright: This script is Copyright (C) 2000 Renaud Deraison

Cables, Connectors

IBM M1015 SAS2 SATA3 PCI-e RAID Controller Card+ 8087 to 4x8482
$52.99
IBM M1015 SAS2 SATA3 PCI-e RAID Controller Card+ 8087 to 4x8482 pictureIBM M1015 SAS2 SATA3 PCI-e RAID Controller Card+8087 to sata
$36.99
IBM M1015 SAS2 SATA3 PCI-e RAID Controller Card+8087 to sata pictureORICO NS500RU3 5 Bay USB3.0 Hard Drive Dock with Raid Support 50TB storage UASP
$299.0
ORICO NS500RU3 5 Bay USB3.0 Hard Drive Dock with Raid Support 50TB storage UASP pictureAdaptec Controller Card 2287101-R 16Port 12Gb/s SAS/SATA RAID Card pci-e x8 Low
$792.99
Adaptec Controller Card 2287101-R 16Port 12Gb/s SAS/SATA RAID Card pci-e x8 Low  picture


Discussions

No Discussions have been posted on this vulnerability.