Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> CGI abuses >> AN-HTTPd tests CGIs


Vulnerability Assessment Details

AN-HTTPd tests CGIs

Vulnerability Assessment Summary
Searches for the existence of several CGIs

Detailed Explanation for this Vulnerability Assessment

At least one of these CGIs is installed on the remote server :

cgi-bin/test.bat
cgi-bin/input.bat
cgi-bin/input2.bat
ssi/envout.bat

It is possible to misuse them to make the remote server

execute arbitrary commands.
For instance :
http://www.xxx.yy/cgi-bin/input.bat?|dir..\..\windows
would show a complete directory listing of the remote system's
private 'C:\windows\' directory.

Solution : Upgrade to the latest version of AN-HTTPd
(http://www.st.rim.or.jp/~nakata/), or contact your vendor
for a patch, or consider changing your HTTP server software.


Network Security Threat Level: High

Networks Security ID: 762

Vulnerability Assessment Copyright: This script is Copyright (C) 1999 Renaud Deraison

Cables, Connectors

Knoppix Linux Live USB 32 64 bit Debian GNU Apache MySQL | Tech | Bootable | OS
$11.0
Knoppix Linux Live USB 32 64 bit Debian GNU Apache MySQL | Tech | Bootable | OS pictureKnoppix 7 Linux DVD 32-bit Full Installation Includes Complimentary UNIX Academy
$14.24
Knoppix 7 Linux DVD 32-bit Full Installation Includes Complimentary UNIX Academy pictureKNOPPIX 8.1 LINUX LIVE DVD - 2018
$6.99
KNOPPIX 8.1 LINUX LIVE DVD - 2018 pictureKnoppix Linux , 32 Bit
$5.99
Knoppix Linux , 32 Bit picture


Discussions

No Discussions have been posted on this vulnerability.