Vulnerability Assessment & Network Security Forums



If through a vulnerability assessment, a network security issue is detected for the vulnerability below, applying the appropriate security patches in a timely matter is very important.  If you have detected that your system has already been compromised, following CERT's Network Security recovery document will assist with recommended steps for system recovery.


Home >> Browse Vulnerability Assessment Database >> Windows >> Sun Java Applet Invocation Version Specification


Vulnerability Assessment Details

Sun Java Applet Invocation Version Specification

Vulnerability Assessment Summary
Checks for older versions of the Java SDK and JRE

Detailed Explanation for this Vulnerability Assessment

The remote version of Windows contains a version of the Java JRE
which is older than 1.4.2_06 / 1.3.1_13.

Even if a newer version of this software is installed, a malicious Java
Applet may invoke a particular version of the Java JRE to be executed with.

As a result, a rogue java applet may exploit this vulnerability to request
to be executed with a known to be buggy version of the Java JRE.


Solution : De-install older versions of the Java JRE
Risk factor: High

Networks Security ID: 11757

Vulnerability Assessment Copyright: This script is Copyright (C) 2004 Tenable Network Security

Cables, Connectors

New TYAN S5510GM3NR Micro ATX Server Motherboard LGA 1155 Intel C204 DDR3 1600
$53.99
New TYAN S5510GM3NR Micro ATX Server Motherboard LGA 1155 Intel C204 DDR3 1600 pictureSUPERMICRO X7DVL-E MOTHERBOARD SERVER BOARD SUPER MICRO COMPUTER
$39.9
SUPERMICRO X7DVL-E MOTHERBOARD SERVER BOARD SUPER MICRO COMPUTER pictureHP 616572-001 624881-001 miniSAS to 4 SAS/SATA MOLEX cable for HP Microserver
$24.99
HP 616572-001 624881-001 miniSAS to 4 SAS/SATA MOLEX cable for HP Microserver pictureHP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 16GB 1TB MIDLINE
$839.0
HP PROLIANT MICROSERVER G8 CORE I3-3240 3.4GHZ 16GB 1TB MIDLINE picture


Discussions

No Discussions have been posted on this vulnerability.